HOW TO CREATE
A BASIC WEB PAGE USING SEAMONKEY
Table of Contents

- Information ........................................................................................................................................... 3
- Vocabulary ............................................................................................................................................... 4
- Getting Started with FTP .................................................................................................................. 5
  - MAC .................................................................................................................................................... 5
  - PC ....................................................................................................................................................... 6
- Before you Begin Creating Your Web Page ....................................................................................... 7
  - Paint.NET ............................................................................................................................................. 7
- Beginning a New Page ......................................................................................................................... 8
- The SeaMonkey Composer Window .................................................................................................... 9
- Inserting and Manipulating ............................................................................................................... 10
  - Font, Font Size, and Font Colors .................................................................................................... 10
- Changing the Web page Colors ......................................................................................................... 11
- Changing the Web page Background .................................................................................................. 12
- Inserting an Image ............................................................................................................................. 13
  - Manipulating an Image .................................................................................................................... 14
- Adding a Table ...................................................................................................................................... 15
  - Inserting and Manipulating Text in the Table .............................................................................. 16
  - Changing the table Background ...................................................................................................... 16
  - Inserting a Picture in the Table ...................................................................................................... 17
- Internal and External Links .............................................................................................................. 18
- Anchors ............................................................................................................................................... 19
- Email Links ......................................................................................................................................... 20
- Saving Your Web Page ....................................................................................................................... 21
- Publishing Your Web Page ............................................................................................................... 22
  - WinSCP .............................................................................................................................................. 22
  - Fetch ............................................................................................................................................... 23
INFORMATION

SeaMonkey is a free and open source cross-platform Internet suite. SeaMonkey consists of a web browser, HTML editor (SeaMonkey Composer), and an IRC client (ChatZilla). The SeaMonkey Composer is a WYSIWG (What You See Is What You Get) HTML editor which enables people who have little or no prior knowledge of the HTML language to create web pages.

You will need your NEIU NetID and password to upload your web page to ftp.neiu.edu. There is a step by step tutorial on how to find your NetID and create a password on the SCS Tutorial page. If you have problems with your NEIU NetID please contact the HELPDESK (x4357) or visit the SCS computer labs for assistance.

Please refer to SCS’s site (http://neiu.edu/~scs/Downloads.html) to download software. Student Computing Services provides links to 3rd-party software for your convenience. Student Computing Services is not responsible for maintaining the software and makes no claims or guarantees for the software. Computer users are responsible for following the software licensing agreements and restrictions specific to the software.
VOCABULARY

Browser ......................  A program used to view web pages on the internet

Download ....................  Move a file from a server to your local computer.

FTP Account ..................  An amount of space on a server allocated to an individual for the purpose of storing web pages and other files.

FTP .............................  (File Transfer Protocol) transfers and exchanges files from desktop to server.

GIF ...............................  (Graphics Interchange Format) is a bitmap image format/ animated graphics.

HTML .............................  (Hypertext Markup Language) is the predominant language for creating web pages.

JPEG ..............................  A commonly used method of compression for photographic images.

Server .........................  A computer that stores and serves up information and is linked to other computers by communication lines.

Upload ..........................  Move a file from your local computer to a server.

Web Page ........................  A single page of information on the internet.

Website .......................  A collection of related web pages at a common address.

WYSIWYG: ......................  (What You See is What You Get) is a phrase used to describe a system in which content during editing looks similar to the final product.

WYSIWYG application ...  A program such as SeaMonkey Composer that lets you create and edit documents while seeing them as they will be seen and without having to know what happens under the hood.
Getting Started With FTP

A web page that is completed and saved on your computer is not viewable on the internet, so it cannot be viewed by others. In order for the website to be viewable on the internet, you will have to move your web page to a server. Your FTP account is your allotment of space on the NEIU server where you can store your web page so that others can see it. SCS provides WinSCP on the PCs and Fetch on the MACs. Both WinSCP and Fetch software can be downloaded for free.

Before starting your web page, check to see if your FTP account is working properly. The first step is to check if you can log into your FTP account. Once you have successfully logged in your account look for a folder named “http.” If you are having problems with your ‘http’ folder or FTP web account, please contact NEIUport HelpDesk (x4357) or visit the SCS main office located at B-107 (x4390).

Fetch (MAC)

Fetch can be found on the MAC dock.

Your NEIUport NetID is your Username.

Enter your Username and Password.

Once you are connected to ftp.neiu.edu, check if you have the ‘http’ folder.
WinSCP can be found on the desktop.

Your NEIUport NetID is your Username.

Enter your Username and Password.

Once you are connected to ftp.neiu.edu check if you have the 'http' folder.

Type your NetID

Once you have logged into WinSCP FTP you will see a ‘http’ folder. If you do not have this folder, your FTP account is not properly set-up.

If you are having problems with your ‘http’ folder or FTP web account, please contact NEIUport HelpDesk (x4357) or visit the SCS main office located at B-107 (x4390).
Before You Begin Creating Your Web Page

A few recommendations to help you organize your website:

✓ Plan your web pages and website before you begin.

✓ Create a ‘New folder’ or designate a folder on one of your drives on the local computer in which you will store all your website files. Try to avoid mixing these files with other unrelated files. This will make it easier to design a web page.

✓ It is recommended that you save all web pages with the “.html” extension. Also use lowercase letters and avoid spaces in your file names; instead of spaces, use hyphens.

✓ Have all images you plan to use saved in your website folder. Use only images that are in “.gif” or “.jpeg” formats as these work best with most browsers.

Paint.NET

Paint.NET is a free imaging and photo editing software for computers that can run Windows. It features an innovative user interface with support for layers, unlimited undo, special effects and a wide variety of useful tools.

Paint.NET can convert from and to these files: .png, .bmp, .gif, .jpeg, .png, .tiff, and .tga. To convert the files simply click File → Open Image File → File → Save As → and select ‘.jpeg’ or ‘.gif’ in the ‘Save as Type’ field. JPEG format provides the best quality for photo-like images.
BEGINNING A NEW PAGE

PC
To begin SeaMonkey Composer, double-click SeaMonkey on the desktop. If you do not see it on the desktop click on Start→Programs→SeaMonkey.

MACs
SeaMonkey is located on the Dock. (A dock is where the software applications are on a MAC.) On the Dock locate Other Applications, and you will find SeaMonkey.

MACs and PCs
To Access Composer Click on File → New → Composer Page

A blank Composer document will appear on the screen. This is where you will create your web page. The Composer is a WYSIWYG (What You See Is What you Get). The Composer resembles what you see when you create a new word processing document.
THE SEAMONKEY COMPOSER WINDOW

SeaMonkey Composer is similar to text editors and word processing programs. It has the ability to format text size, color, font, alignment (left, center, right, and justify) as well as create numbered and bulleted lists.

At the Bottom of the page there are four tabs:

- **Normal View**
  - Beginners will want to use the Normal View. This view allows users to see the page exactly the way that it will look as a webpage.

- **HTML Source View**
  - Allows users to see the code of the webpage. This view is for those who want to learn HTML or already know HTML.

- **HTML Tags View**
  - Allows users to see the tags used when formatting text and other features used when creating the web page.

- **Preview**
  - Allows users to preview the web page in the SeaMonkey browser.
INSERTING AND MANIPULATING TEXT

You enter text into the HTML document body by typing in the Composer window. Text will wrap around the screen just like a word processing program. Pressing the [Enter] key will insert a hard carriage return and place the cursor at the beginning of the next line.

FONTS, FONT SIZE, AND FONT COLORS

You may change the font, font size, text style, and the text color using the Format Menu. You may also manipulate the text by using the toolbar.

Manipulating text using the toolbar

‘-a’ and ‘+a’ decrease and increase text size respectively

Manipulating, Font Size, and Font Colors

If you wish to manipulate text which has already been typed, you must select the text first by highlighting it before changing its size, or color.
SeaMonkey Composer allows you to change the background of your web page.

To do this, click Format -> Page Colors and Background.

Under Page Colors and Background, you may set the web page to use the Reader’s default colors or to Use custom colors.

If you want to use custom colors, click on the colored boxes next to the categories (normal text, link text, etc...) of the type of text you wish to change.
To change the web page background color, select “Background”. Once you have chosen a color, click the ‘OK’ button.

You may also use an image as the background. To do this simply click ‘Choose File’ in the Page Colors and Background window. Then select the image that you wish to use as the background to your website.

**Note: use the exact file name (abstract.jpg) as opposed to pointing to the image location (file:///C:/Users/****/Pictures/abstract.jpg). This will prevent broken links to your image files when viewing your web page online.**
INSERTING AN IMAGE

Position the mouse cursor or use the keyboard (space bar, tabs, enter, or arrow) in the body and where you want the image to appear. Click the **Image** button on the SeaMonkey toolbar. Alternately, you may click on **Insert** → **Image** from the menu bar. At this point, the **Image Properties** window will appear as shown below.

Click on the **Choose File** button to locate the image you wish to insert into the web page. If you already know the image name, simply type it into the **Image Location** field.

**NOTE:** use the exact file name (new-logo.jpg) as opposed to pointing to the image file location (file:///C:/User/****/Picture/new-logo.jpg), and also use hyphens instead of spaces. This will prevent broken images when you view your web page. **Alternate Text** (will not work with all browsers) can be added to the image properties. This will make a small text box appear whenever the user, places their mouse cursor over your image. For example, let’s say you inserted a picture of a mouse. You can type in the alternate text “Squeak.” Every time the mouse cursor is moved over your image, the word “Squeak” will appear. If you do not want to add alternate text, click the bullet “**Don’t use alternate text.**”
Manipulating an Image

You may change the height and width of an image by double-clicking on it and choosing the **Dimensions** tab. You can assign custom dimension settings to enlarge or reduce the image size.

The **Appearance** tab allows you to adjust spacing and add solid borders around images.
ADDING A TABLE

Tables can be used in your webpage to help organize your information. However, tables should not be used as a layout for the web page.

Tables can be added by clicking on the Table button at the top of the Menu bar.

If you would like your table to span the entire width of the page you may leave the "% of window" at 100, otherwise you have the option to adjust the width. You may also choose the width by "pixels" although "% of window" is the default width setting. The length is determined by the number of rows in your table. You can select the border width by changing the amount of pixels that will pad the cells. After clicking "OK," a border will show up on the SeaMonkey composer page.

Click inside the table, go to Format (located in the tool bar) and click on Table Properties.

Format → Table Properties
INSERTING AND MANIPULATING TEXT IN THE TABLE

You may enter text into the table simply by clicking your mouse in the box in which you want to enter text. The text length will determine the column width. Pressing the [Return] key will insert a hard carriage return and place the cursor at the beginning of the next line within the table, but note a second line will be added to the entire row.

You can change the font properties using the Format menu or you can also change the text by using the tool bar.

CHANGING THE TABLE OR CELL BACKGROUND

To change the Table background, click on the Table menu and choose Table or Cell Background Color.

The Table or Cell Color window will open. To select a table background color, click Table, select a color, and click “OK”. The table background color will change to the color you selected.

To change the background of a cell, select the cell you want to change and click in the cell making sure your cursor is in the proper cell. To change the cell color, click on the Table menu and choose Table or Cell Background Color. To select a cell background color, click Cell(s), select a color, and click “OK”. The cell background color will change to the color you selected.
To insert a picture into a table, select the location, and click Insert from the Main menu. The Image Properties window will open and you may choose which file you want to insert. Remember to rename your picture file to it’s original name as stated in the “Inserting an Image” section.
INTERNAL AND EXTERNAL LINKS

One of the most important features of a web page is that it contains links to other sites on the Internet. Links provide a quick and convenient way to take users to other web pages by simply clicking on them instead of typing the full address into the location bar.

When clicked, Internal Links take the user to another web page or portion of a web page on the current website. The method used to create an internal link is similar in concept to external links. The only difference is that the internal links reference anchors/targets, local files, or local web page files.

Creating an internal or external link involves one of two elements in your web page. In pure HTML, you may use text or an image to make a link. To begin, choose the text or image that will serve as the link. In the case of text, highlight the text with your mouse cursor. In the case of an image, click on it once to select it.

**Note: Internal, External, Anchor, and E-mail Links will not work until your web page has been published to your NEIU server. Please refer to the “Publishing Your Webpage” section for more details on how to publish your website. **

Highlight the text that you want to link -> Select the link button on the tool bar -> The Link Properties box will open -> Enter a URL from the WWW or Chose a file to a page within your web site that you want to link to -> Click OK.
Click on the page where you want the anchor to be. Click Insert -> Named Anchor.

A new window will appear. In the Named Anchor Properties name your anchor and the Anchor symbol will appear on the webpage.

Highlight the text you want to be the link for the anchor. Click Link -> #anchornname -> OK.
E-MAIL LINKS

Adding an e-mail link allows your web page viewers to contact you. The procedure to create an email link is very similar to creating an external link.

First, highlight or click on the text or image, then click on the link button on the tool bar.

Type the text you want to link to the email address -> Highlight the text -> Click on the Link button on the tool bar -> Type in mailto:emailaddress@whatever.com into the Link Location box -> Click OK.
SAVING YOUR WEB PAGE

Be sure to save your work frequently. This will help ensure that your work will not be lost in the event of a computer failure or power outage. To save your web page, click on **File ➔ Save** from the SeaMonkey File menu. If you have not given your web page a title, you will see the **Page Title** menu box appear. After you give your webpage a title, press OK.

The Internet standard for HTML web publication is to have the primary or first web page files called `index.html` in order to be recognized by any and all HTML compliant web browsers. Contrary to popular belief, you should NOT name your web page `home.html`. It is acceptable to name your web page `index.htm` but you should use a full `.html` extension on all HTML files whenever possible. Be sure to delete the placeholder `home.html` that will be in your `http` folder or it may interfere with your new web page. Remember to use lowercase letters and avoid using spaces, using hyphenation instead.
Once you have finished editing and tweaking your web page, you should publish it to your http folder and see how it looks in a web browser. To do this, use WinSCP or Fetch.

Please remember that you have to upload all files (web page (index.html), images, sounds and video clips) to your NEIU account. To do this connect to your FTP account, a window like this one below will appear. The next step is to double click on all of the files associated with your web page. The files will be copied from the local computer (the computer you are working on) to your FTP account. To download files to your FTP account drag your files from the local computer to the ‘http’ folder. It is strongly suggested that you save your web files and picture together in the same folder and not in different folders as mentioned earlier in this tutorial.

Drag and drop your web page, images, sound files, and video files into your http folder.

If you followed these instructions, your web page will be viewable by going to http://www.neiu.edu/~(your NetID)
Once you have connected to ftp.neiu.edu through Fetch, click on ‘Put.’ This will open a new window that asks you to choose the items you want to put on ftp.neiu.edu. Locate your files (index.html, picture, videos, etc.) and click on ‘Put.’

If you have done it correctly you will be able to see your files in the ‘http’ folder.

If you followed these instructions, your web page will be viewable by going to http://www.neiu.edu/~(your NetID)